Composer普遍不正确是啥
时间:2021-04-25

本文关键详细介绍Composer普遍不正确是啥,原文中详细介绍的十分详尽,具备一定的实用价值,很感兴趣的朋友们一定要看了!

Composer普遍不正确解决方法

实行composer install碰到不正确:Your requirements could not be resolved to an installable set of packages. 这是由于不配对composer.json规定的版本号。

详细不正确以下:

提醒我的PHP 7版本号太高,不符composer.json必须的版本号,可是在PHP 7下应当也是能够 运作的,composer能够 设定忽视版本号配对,指令是:

或是

再度实行composer指令能够 一切正常安装文件了。

假如提醒警示:

它是在vm虚拟机中实行composer,提醒这一文件目录沒有可写管理权限,composer没法缓存文件免费下载的包,那样就每一次都得再次免费下载,把文件目录改为应写可写就可以。

此外,在vm虚拟机中也设定composer为国内镜像,要不然下载速度慢的要死了,实行:

之上是“Composer普遍不正确是啥”本文的全部內容,谢谢诸位的阅读文章!期待共享的內容对大伙儿有协助,大量有关专业知识,热烈欢迎关心程序猿领域文化频道!